PDA

Afficher la version complète : Pure virtual function call



Eddyjazz
28/10/2006, 12h48
Hello,

J'ai enormement de problemes avec ce jeu, le plus genant etant qu'apres avoir tourne correctement une fois le jeu ne peut plus etre lance !

Une boite de dialogue apparait avec ce message :

Microsoft Visual C++ Runtime Library
Runtime Error!
Program : [...]mm.exe
R6025
- pure virtual function call

Detail amusant, si je lance a partir du launcher (en inserant le dvd par exemple) et que je selectionne : Desinstaller -> repair
le jeu est a nouveau pret a "fonctionner" !

J'ai virer les HDR des options videos, sinon le jeu plantait apres avoir selectionne le niveau de difficulte des combats.

Le dvd a manifestement des soucis pour etre lu, j'ai du faire plusieurs tentatives pour qu'une dll accepte de s'installer sans erreur de crc (c'est le seul dvd qui me fasse ca). La derniere installation c'est bien passee.

J'ai modifie le raccourcis bureau pour rajouter "-dxlevel 90c". Ca n'a rien change.
Mon directX est detecte en Directx 9.0+

Je tourne sous Windows XP sp2, Athlon 3.5 2Go CM Azus chipset nvidia. Video nvidia 7800 GT

J'ai achete la version collector.

J'ai passe un coup d'anti virus/anti spyware pour etre sur, aucun soucis.

Donc pour pouvoir jouer actuellement il faut que je commence par faire un repair de l'install, ce qui ne me semble pas normal http://forums.ubi.com/infopop/emoticons/icon_wink.gif

Si quelqu'un a une idee pour m'aider ...

Eddyjazz
29/10/2006, 05h49
Suite de mes aventures, des fois que ca puisse aider quelqu'un, y compris les devs.

Pour pouvoir jouer aujourd'hui, hier soir je fait un repair de mon jeu.
Je lance le jeu jusqu'a l'ecran d'accueil (demarrer une partie, options, credits, etc...) pas de pure virtual.
Je ne lance surtout pas de partie pour pas tout perdre.
Je verifie tout est toujours fonctionnel en relancant le jeu jusqu'a l'ecran d'accueil une seconde fois, niquel.
J'eteins le pc, dodo.
Aujourd'hui je demarre le pc, je vois du coin de l'oeil Steam qui met a jour un truc (alors que Steam ne semblait pas voir le jeu installe, ne me proposant que de downloader la version solo et/ou multi).
Je lance le jeu, pure virtual function !
Je me dis que j'ai trouve le fautif, et comme c'est le solo qui m'interresse je desinstalle Steam.
Et la surprise : sans rien me demander, et surtout pas de conserver mes sauvegardes (!), il efface le repertoire du jeu ! Et je dis bien effacer, pas desinstaller : la base de registre contient encore des trucs, et quand je met le dvd il croit toujours que le jeu est installe...
Mais plus de repertoire sur le disque dur, merci Steam...

Me voila donc encore oblige de faire un repair (puisque le jeu est "installe", je ne peux pas faire install, et comme je crois qu'on ne peut pas choisir de ne pas installer Steam, ca m'arrange finalement)., sauf que la j'ai plus de sauvegardes (j'etais pas loin, mais pour le principe c'est gavant).

Une fois le jeu "repare", pas de pure virtual, pas de sauvegardes http://forums.ubi.com/infopop/emoticons/icon_frown.gif , mais il a garde ma configuration graphique (c'est vrai que c'est plus important que des sauvegardes de parties...).

Et la, "miracle", je peux lancer une partie, quitter le jeu, relancer une partie, etc ....
Plus de "Pure virtual function call" !

Donc dans mon cas, c'etait Steam qui me pourrissait la vie.
Comment faire pour jouer en reseau, vue qu'on est pied et poings lies avec Steam?
Mystere...

Mais au moins je peux jouer http://forums.ubi.com/infopop/emoticons/icon_smile.gif

Je ne connais pas du tout Steam (ni PlayLinc), mais je crois qu'on peut dire qu'il n'est pas bien integre au jeu :/