PDA

Afficher la version complète : Latence persistante !!!



magicarts
19/10/2012, 18h58
Bonjour/bonsoir

Je vous expose mon problème : suite à l'instal. de Rocksmith sur mon PC je rencontre des problème de latence au niveau du son (du genre 20ms)
Autant dire que c'est complètement injouable.

Ce que j'ai essayé :

_ procédé au réglage du moteur audio sur 1 via les options du jeu (il y a eu du mieux mais c'est pas encore ça)

_ brancher un dac usb sur mon Home-cinéma ----- rien

_brancher mon PC directement sur mon Home-cinéma ----- rien

_Bancher mon casque directement sur le PC ----- rien


Y aurait-il des options dans le jeu que je n'est pas vu pour remédier au problème ?
Est ce que vous rencontrez une légère latence comme moi ?

Ubi-Cosmos
22/10/2012, 00h36
Bonsoir,

Votre PC est branché sur une télé ou sur un écran d'ordinateur ? Si c'est sur une télé, veillez à bien mettre le mode "Jeux".

magicarts
22/10/2012, 10h58
Mon PC est branché en HDMI sur ma télé LCD (juste la partie image)
Et pour le son je passe par la prise casque du PC vers mon ampli avec un cordon (2xRCA-jack 3.5) c'est le meilleur résultat que j'ai pu obtenir ( latence de 20ms)

Ce que je voudrais savoir c'est si quelqu'un arrive à éliminer la latence complètement entre le son et l'image ?
ou si via une vrai carte son (style auzentech) il y a du mieux car je passe par la sortie de la carte mère.

Ubi-Cosmos
22/10/2012, 11h42
D'accord. Cela peut effectivement venir de la carte son, qui serait "trop lente" pour la conversion du signal. Attention, je n'émets qu'une hypothèse. Soit il faut voir avec le retour d'autres joueurs, soit je vous invite à contacter le support technique.

magicarts
22/10/2012, 12h25
Merci @Ubi-Cosmo, je vais attendre quelques retours de joueurs avant d'acheter une carte son interne ...

Si comme moi vous avez ce problème de latence, ou si vous avez résolu le problème, n'hésitez pas à en faire part ici.

jmpoirier
22/10/2012, 13h49
Je n'ai pas encore constaté de gros problèmes de latence. Ca me choquera peut-être plus lorsque j'aurai progressé. As-tu essayé de jouer avec les paramètres du fichier .ini comme indiqué sur cette page (http://forums.ubi.com/showthread.php/716851-Rocksmith-PC-Configuration-and-FAQ-s) (en anglais) ? Il y a plusieurs paramètres qui peuvent être changés pour essayer de résoudre un problème de latence non résolu autrement :cool:

magicarts
22/10/2012, 21h34
ma latence est de 20 ms jmpoirier, c'est vraiment faible mais ayant l'oreille musicale ça devient vraiment gênant dans certain cas et j'ai peur pour la suite car j'en suis qu'au début du jeu. :(

Cela dit je m'éclate quand même :D

En ce qui concerne le "fichier.ini" la seul modification que j'ai apporté est pour "ForceWDM" en remplaçant 0 par 1 mais suite à ça le jeu tourne sans le son.
Donc j'ai tout laissé par défaut.

J'ai même fait le test de baisser la résolution vidéo mais rien de mieux.

Je crois que la carte son va ètre de rigueur :(

CrocPoulet
22/10/2012, 21h35
20 ms ça me semble un bon resultat et je ne pense pas que t'obtiendra mieux sachant que dejà le décalage vidéo en lui même est en général de l'ordre de 50 ms.
Les bonnes cartes sons garantissent une latence autour de 10 -20 ms je crois, normalement ce n'est pas perceptible

magicarts
22/10/2012, 22h01
Oui c'est un bon résultat, je ne dis pas le contraire.
Je faisais la comparaison avec un iBidule que je branche sur mon iTéléphone et qui permet d'avoir une multitude de son et qui marche au quart de tour sans latence.
surement mon coté En....leur de mouche qui prend le dessus :p

andludo
23/10/2012, 14h53
Pour ma part, je sais pas si c'est de ca dont tu parles, mais moi j'ai un décalage entre le moment ou je gratte la corde et ou le son retenti dans le jeu... autant dire que ca devient du delire de chercher a jouer en avance sur la musique... :eek:

quelqu'un a une idée de comment regler le probleme car bon , c'est plus de la musique la..

je suis sous mac en passant par parallels desktop.
en dehors de ca, tout est nickel, fluidité image etc..

andludo
23/10/2012, 15h19
Pour ma part, je sais pas si c'est de ca dont tu parles, mais moi j'ai un décalage entre le moment ou je gratte la corde et ou le son retenti dans le jeu... autant dire que ca devient du delire de chercher a jouer en avance sur la musique... :eek:

quelqu'un a une idée de comment regler le probleme car bon , c'est plus de la musique la..

je suis sous mac en passant par parallels desktop.
en dehors de ca, tout est nickel, fluidité image etc..

Donc je viens d'approfondir mon probleme, j'ai joué sur les notes VISUELLE (ce qui visiblement par le jeu est calé) et une fois a la fin de la chanson en réécoutant, il y a bien toujours le décalage....comme quand je suis dans le mode Ampli.

Pour info, il n'y a aucun décalage quand je suis dans GarageBand (logiciel de musique mac) avec le cable Real Tone UBI ...

Au secours..

magicarts
23/10/2012, 16h33
Pour ma part, je sais pas si c'est de ca dont tu parles, mais moi j'ai un décalage entre le moment ou je gratte la corde et ou le son retenti dans le jeu... autant dire que ca devient du delire de chercher a jouer en avance sur la musique... :eek:

Ca m'a l'air d'etre le même problème andludo.
Ha !!! je suis content que quelqu'un le remarque :D.
Donc je suis pas fou lol
Ce que je trouve dingue c'est que sur mon Phone avec Mobile-in il n'y a aucune latence lorsque je joue, et ce n'est qu'un téléphone.

(Je pense qu'un billet a UBISOFT va être de rigueur)

andludo
23/10/2012, 16h52
Ca m'a l'air d'etre le même problème andludo.
Ha !!! je suis content que quelqu'un le remarque :D.
Donc je suis pas fou lol
Ce que je trouve dingue c'est que sur mon Phone avec Mobile-in il n'y a aucune latence lorsque je joue, et ce n'est qu'un téléphone.

(Je pense qu'un billet a UBISOFT va être de rigueur)

Non non t'es pas fou ;)
En revanche je suis pas certain qu'on est le meme probleme car moi je gratte la corde et juste apres j'entends le son... ya quand meme un sacré decalage... je mettais ca sur le compte de win7 via Parallels sur mac.. que le son devait rentrer sur mac (malgré que je choisis win7 au moment du plug de la guitare) passer dans win7 et faire le trajet inverse..

Toi tu es uniquement sur PC et tu as le meme probleme ou moins flagrant ?
Tu as tenté d'appeler le service technique d'UBI ?

Pour bien faire faudrait que j'essaie via Bootcamp...

magicarts
23/10/2012, 17h55
Pour ma part c'est le même problème , mais en moins prononcé. Je gratte ma corde et le son viens ensuite genre un huitième de seconde après.
J'ai l'impression de retourner 10 ans en arrière lorsque j'ai acheté mon premier delai boss
Ça me donne limite une amplitude à ma note

magicarts
26/10/2012, 10h42
Je viens d'envoyer un ticket à UBISOFT, je vous tiens au jus dés que j'ai une réponse.

theblackmage66
28/10/2012, 13h19
j'ai moi aussi le même problème je ne pense pas que sa vienne de mon pc, j'ai pour ma part une config plus que suffisante ( i5 2500k avec une gf 560ti 448 core ). La ou le problème est flagrant c'est quand j'émule la basse sur ma guitare. Je suis assez déssus d'avoir dépencer autant d'argent et de voir que sa devient injouable quand on a une bonne notion du rithm ( 6 ans de guitare ). Un pote a trouvé un crack pour faire marcher le jeu avec un vrai cable jack et il ne rencontre pas se problème. C'est surement dû au faite qu'il est branché directement sur la carte son plus tôt que de passer par de usb qui génère de la latence... Je pense que je vais m'acheté un adaptateur mini jack pour relier directement un vrai jack à ma carte son et voir si j'ai toujours se problème. ah si j'avais su j'aurais pas acheté le jeu vu que la version craker marche très bien et sans cette merde de steam qui augmente la latence dpc...
Voici un screen qui prouve que mon pc est très bien pour géré de l'audio http://nsa31.casimages.com/img/2012/10/28/mini_121028013944335720.png (http://www.casimages.com/img.php?i=121028013944335720.png)

J'ai aussi remarqué que se décalage est plus ou moins flagrant selon la chanson surement dû au faite que le son de la guitare est différent, donc je commence a me dire si le problème viendrait pas de la carte son. Mais bon quand je vois que la latence dpc de mon ordi est aussi faible, j'ai un peu de mal à me dire que sa vient de ma carte son...

magicarts
29/10/2012, 12h10
J'ai aussi remarqué que se décalage est plus ou moins flagrant selon la chanson surement dû au faite que le son de la guitare est différent, donc je commence a me dire si le problème viendrait pas de la carte son. Mais bon quand je vois que la latence dpc de mon ordi est aussi faible, j'ai un peu de mal à me dire que sa vient de ma carte son...

-J'ai remarqué aussi que suivant les chansons le décalage était différent.
-Et je pense aussi que le Real Tone Cable est à l'origine de cette latence

(maintenant que j'y repense Ubisoft conseil une sortie audio via la prise jack verte du PC pour de meilleur perf, mais en entrée le son passe par ce P..tain de câble qui est USB et qui forcement ralenti le flux audio) c'est pas contradictoire ça :confused:

Tiens moi au courant pour ton adaptateur mini jack et la carte son, ça m’intéresse :p

jmpoirier
30/10/2012, 10h45
Je suis tombé sur deux sujets en anglais qui m'ont semblé intéressants pour lutter contre le phénomène de latence sur PC, ICI (http://forums.ubi.com/showthread.php/282374-Got-Lag-Got-Latency-READ-THIS-FIRST-Forums) et LA (http://forums.ubi.com/showthread.php/719817-A-guide-to-achieving-low-latency-in-Rocksmith-on-PC-Forums).

magicarts
30/10/2012, 12h20
Je suis tombé sur deux sujets en anglais qui m'ont semblé intéressants pour lutter contre le phénomène de latence sur PC, ICI (http://forums.ubi.com/showthread.php/282374-Got-Lag-Got-Latency-READ-THIS-FIRST-Forums) et LA (http://forums.ubi.com/showthread.php/719817-A-guide-to-achieving-low-latency-in-Rocksmith-on-PC-Forums).

Cool, merci ! je devrais trouver mon bonheur dessus, je regarde en profondeur dés que possible.

jmpoirier
31/10/2012, 17h18
J'ai fait plusieurs manip. Je me suis rendu compte que mes drivers pour les composants audio étaient sacrément datés, hop: mise à jour. Ensuite j'ai nettoyé Windows 7, bidouillé un peu la base de registre et la configuration. Enfin, et surtout, j'ai fait les modifications dans le fichier .ini de Rocksmith.

Et bien ce n'est pas parfait, mais c'est nettement mieux. J'attends de voir ce que ça donnera à deux joueurs: les fameux craquements se produiront-ils suite à la réduction du buffer m'obligeant à le ré-augmenter et à rallonger le temps de latence ?

theblackmage66
01/11/2012, 12h48
Dans 15 minutes je vais pouvoir tester le crack je vous tiens au jûs si sa vire se vieux décalage. Sinon j'arrive à d'assez bons résultats avec le cable real tone mais le décalage persiste sur certaines chansons.

magicarts
02/11/2012, 09h17
Dans 15 minutes je vais pouvoir tester le crack je vous tiens au jûs si sa vire se vieux décalage. Sinon j'arrive à d'assez bons résultats avec le cable real tone mais le décalage persiste sur certaines chansons.

Cool :cool:
En ce qui concerne ma demande à Ubisoft ils m'ont demandé les info de mon pc que j'ai envoyé, mais depuis samedi pas de nouvelles.

theblackmage66
07/11/2012, 16h18
Moderation

kenrio7
07/11/2012, 17h03
Modération.

je suis pas sur que ça soit très malin de dire ça, autant Ubisoft me fais gerber autant dire au gens d'aller chopper un crack pour rattraper une latence que certains ont et pas d'autres...

aucune latence sur mon pc et ma xbox...

magicarts
08/11/2012, 00h52
je suis pas sur que ça soit très malin de dire ça, autant Ubisoft me fais gerber autant dire au gens d'aller chopper un crack pour rattraper une latence que certains ont et pas d'autres...

aucune latence sur mon pc et ma xbox...

D'accord avec toi, mais de ce fait, cela pourrait remètre le Real Tone Cable en cause :confused:

NB: Tjr pas de nouvelles de la part d'UBISOFT pour mon problème depuis le 27/10/2012, je crois que je vais me manifester...

Ubi-Cosmos
08/11/2012, 01h50
Bonsoir,

Pour le moment je n'ai pas de nouvelle. Je vais les relancer.

magicarts
08/11/2012, 02h04
Bonsoir,

Pour le moment je n'ai pas de nouvelle. Je vais les relancer.

J'en ai fais autant de mon coté via le ticket.

Ubi-Cosmos
08/11/2012, 02h18
J'en ai fais autant de mon coté via le ticket.

Très bien.

magicarts
15/11/2012, 11h19
@Ubi-Cosmo as tu eu des news concernant mon problème de latence ? car moi j'ai toujours aucunes réponses de la part d'UBISOFT depuis que je leur ai envoyé les infos de mon pc.
Pratiquement 1 mois de silence, j'ai vraiment l'impression qu'il se moque de moi...:mad:

doremifasolla
19/11/2012, 12h28
il faut vérifier la chaine
1:guitare ok
2:micros de la guitare ok
3: prise jack de la guitare ok
4:le câble real tone ok
5:tester les différent port usb ok
6:régler les paramètre windows son le volume du micro entre 30 et 40
puis 48khz ok
7:choisir plus la sotie son rca que le hdmi ok
8:dans le jeux régler le moteur audio a 1 ok

magicarts
20/11/2012, 20h39
il faut vérifier la chaine
1:guitare ok
2:micros de la guitare ok
3: prise jack de la guitare ok
4:le câble real tone ok
5:tester les différent port usb ok
6:régler les paramètre windows son le volume du micro entre 30 et 40
puis 48khz ok
7:choisir plus la sotie son rca que le hdmi ok
8:dans le jeux régler le moteur audio a 1 ok

Ce sont les premières choses que j'ai fait mais toujour une latence.

20/11/2012 ...

UBISOFT n'a toujour pas donné signe de vie pour mon ticket. (plus d'un mois, si ça c'est pas de la patience :p)

killergege83
21/11/2012, 12h37
Personnellement, j'ai appliqué les conseils que tu peux trouver sur ce site, suite à de sérieux problèmes de latence :
http://forums.ubi.com/showthread.php/719817-A-guide-to-achieving-low-latency-in-Rocksmith-on-PC-Forums

L'étape 2 a été très efficace en ce qui me concerne !
Le jeu est désormais à peu près jouable. A noter que j'ai un PC très performant (je joue généralement avec tous les paramètres au maximum dans tous mes jeux) et mon système est sur un SSD (pas encore essayé de déplacer le jeu dessus par contre).

Si tu ne lis pas l'anglais, en gros :

Mettre à jour les pilotes de la carte son, et si tu en as plusieurs, sélectionner la plus performante (je ne sais pas comment il teste la performance de sa carte par compte).
Modifier les paramètres du fichier rocksmith.ini et notamment modifier ces valeurs :

ExclusiveMode doit valoir 1
Changer les valeurs de MaxOutputBufferSize et LatencyBuffer. jusqu'à trouver une valeur qui fonctionne bien. En gros commencer avec LatencyBuffer à 1 et MaxOutputBufferSize à 1024 puis diminuer MaxOutputBufferSize par dichotomie (diminue de moitié à chaque fois) jusqu'à trouver une valeur qui marche bien. Pour tester les valeurs : enregistrer le fichier et lancer le jeu. Si le son est correct lors de la vidéo d'intro, c'est bon ou tu peux essayer de diminuer la valeur, si le son grésille ou disparait, il faut l'augmenter. Si ça ne marche pas dès le début, tester en augmentant LatencyBuffer de 1 et réessayer de changer MaxOutputBufferSize en partant de 1024.
Personnellement, mes paramètres idéals sont LatencyBuffer à 1 et MaxOutputBufferSize à 160. J'ai quelques grésillements dans certaines chansons donc je vais probablement l'augmenter un peu, à 180 ou 200.

La troisième partie n'est pas vraiment détaillée et indique un lien vers d'autres astuces de paramétrage de l'ordinateur.

JPhedre
21/11/2012, 14h14
Cette doc est aussi accessible en francais, en pdf dans le repertoire d'install du jeu, avec aussi des conseils pour tester la puissance de tes "prises" usb!

killergege83
21/11/2012, 14h33
Ah bon ?? Ah bah c'est cool alors, je regarderais ça. Je suis tellement habitué aux docs faiblardes et incomplètes que je n'ai même pas pensé à y jeter un oeil !

magicarts
21/11/2012, 20h00
Personnellement, j'ai appliqué les conseils que tu peux trouver sur ce site, suite à de sérieux problèmes de latence :
http://forums.ubi.com/showthread.php/719817-A-guide-to-achieving-low-latency-in-Rocksmith-on-PC-Forums

L'étape 2 a été très efficace en ce qui me concerne !
Le jeu est désormais à peu près jouable. A noter que j'ai un PC très performant (je joue généralement avec tous les paramètres au maximum dans tous mes jeux) et mon système est sur un SSD (pas encore essayé de déplacer le jeu dessus par contre).

Si tu ne lis pas l'anglais, en gros :

Mettre à jour les pilotes de la carte son, et si tu en as plusieurs, sélectionner la plus performante (je ne sais pas comment il teste la performance de sa carte par compte).
Modifier les paramètres du fichier rocksmith.ini et notamment modifier ces valeurs :

ExclusiveMode doit valoir 1
Changer les valeurs de MaxOutputBufferSize et LatencyBuffer. jusqu'à trouver une valeur qui fonctionne bien. En gros commencer avec LatencyBuffer à 1 et MaxOutputBufferSize à 1024 puis diminuer MaxOutputBufferSize par dichotomie (diminue de moitié à chaque fois) jusqu'à trouver une valeur qui marche bien. Pour tester les valeurs : enregistrer le fichier et lancer le jeu. Si le son est correct lors de la vidéo d'intro, c'est bon ou tu peux essayer de diminuer la valeur, si le son grésille ou disparait, il faut l'augmenter. Si ça ne marche pas dès le début, tester en augmentant LatencyBuffer de 1 et réessayer de changer MaxOutputBufferSize en partant de 1024.
Personnellement, mes paramètres idéals sont LatencyBuffer à 1 et MaxOutputBufferSize à 160. J'ai quelques grésillements dans certaines chansons donc je vais probablement l'augmenter un peu, à 180 ou 200.


La troisième partie n'est pas vraiment détaillée et indique un lien vers d'autres astuces de paramétrage de l'ordinateur.



Merci pour toutes ces info, je regarde ça de plus prés des que possible.:D

Mon PC est à jour et le système sur SSD, mais comme toi le jeu est sur HDD (possible que sa l'améliore)


MAJ 25/11/2012

Après réinstallation de tout mon système et également de Rocksmith, j'ai approfondi mes réglages via de fichier.ini

j'ai également pu régler LatencyBuffer à 1 et MaxOutputBufferSize à 160
Ce qui améliore effectivement le problème :)
( c'est comme une résurrection lol)

En dessous (MaxOutputBufferSize à 128) le son de la video crépite également, mais est ce possible de déscendre par tranche de 16 ? (160-16=144)
J'en doute mais je pose quand même la question.

Je vais également basculer le jeu sur mon SSD afin de voir si il y a une amelioration.

magicarts
21/12/2012, 20h55
bonsoir, je vien d'avoir à l'instant une réponse de UBISOFT pour mon probleme de latence (qui et résolu depuis un bout de temp, merci killergege83 )
Je vous laisse lire leur solution miracle :

"Bonjour,

Merci d’avoir contacté le Support Technique d’Ubisoft concernant Rocksmith.

Pour répondre à ce courriel, utilisez le lien ci-dessus. Ne répondez pas à cet e-mail depuis votre boite de réception, et ne créez pas de nouvel incident.

Nous tenons à nous excuser de la réponse tardive à votre courriel.


La configuration de l’audio est importante pour avoir la meilleure expérience et performance avec Rocksmith sur PC. Si votre système d’audio n’est pas configuré correctement, vous pouvez avoir des problèmes de lag entre la guitare et le son.

Pour configurer la sortie audio :
Ouvrez le panneau de configuration son et sélectionnez « Lecture. » Le périphérique que vous voulez utiliser devrait être le « Périphérique par défaut. » Sélectionnez le périphérique et cliquez sur Configurer.

Cela devrait ouvrir le panneau de configuration pour le haut parleur. Utilisez ce panneau pour choisir le canal 2 stéréo. Une fois que vous avez complété les étapes ici et vous êtes retourné à l’onglet « Lecture » sur le panneau de configuration son, sélectionnez encore le périphérique puis cliquez sur « Propriétés »
Ici, sélectionnez les options avancées. Vous devez mettre la sortie à 16 bit, 48000 Hz. Vous devez aussi cochez l’option pour permettre à l’application de prendre contrôle du périphérique. Si vous en avez la possibilité, cochez l’option de donner les applications en mode exclusive priorité.

Configuration Audio Rocksmith :
Pour de meilleurs résultats, vous devez aussi configurer les options audio dans le jeu.
Depuis le menu principal, choisissez Options. Après, Son & Affichage.
Ici vous devez avoir 2 options que vous pourrez changer. Le premier concerne les paramètres d’engin audio. Le plus bas les numéros sont, meilleure est la performance. Mais le plus bas ces numéros sont , le plus exigeant est le jeu sur votre système. Pour les ordinateurs neufs à haut performance, nous recommandons 2.
L’autre option est l’exclusivité audio. Cet option donne l’application le droit d’utiliser le périphérique son exclusivement. En général, cela donne au jeu plus de contrôle sur les paramètres audio et devrait améliorer la performance. Mais, vous n’allez pas entendre d’autres sons quand le jeu est en cours et quelques applications peuvent avoir besoin d’être relancé pour avoir du son après. Si vous voulez faire cela, vous pouvez simplement selectionnez « True » ou « Vrai. »

Périphériques Audio :
Tandis que Rocksmith supporte l’utilisation des haut-parleurs et Casque USB, en général nous ne les recommandons pas.
Si vous avez des périphériques audio que vous n’utilisez pas, je vous recommande de les desactiver/deinstalle les pilotes avant de jouer.

Si vous avez d’autres questions ou si vous rencontrez d’autres problèmes n’hésitez pas à nous contacter à nouveau.

Cordialement,"

Autant dire qu'ils ont recopier la notice du jeu ...
Merci les gars pour avoir bûché 2 mois pour me lire la notice !