PDA

Afficher la version complète : Impossible de réinstaller Anno 2070.



Quazarn
04/11/2015, 20h06
Bonjour,

Dans la nuit d'hier en voyant la sortie d'Anno 2205 j'ai eu l'envie de rejouer à Anno 2070 à défaut de pouvoir acheter le 2205 dans l'immédiat. Ce matin je vois avec satisfaction qu'il est prêt au lancement. Je le lance et je tombe sur le fameux message de redémarrage puisque je possède Deep Ocean. Et c'est là que les problèmes commencent. Et parler de problème est un euphémisme.

- Anno 2070 s'est mis à tourner dans le vide, a chaque redémarrage l'autopatcher cessait de fonctionner et relancer le jeu dans la foulée. Après une dizaine de ratage, j'ai lâché l'affaire et je me suis mis à chercher une solution. Je me suis aperçus que Uplay n'était pas installé à la racine même du disque C mais dans Program files (x86). Connaissant les déboires de cette plateforme et vu que dès que je m'en sers y'a un truc qui foire, j'ai compris que le problème venait sans hésitation de là.

- Par un oublis, j'ai déplacés tout le répertoire au lieu de le copier. Et lorsque j'ai lancé une désinstallation par le panneau de configuration celle-ci a aboutis à une suppression pur et simple de l’icône sans aucune forme de désinstallation. Le contenue du jeu n'étant plus là, je pensais que ça aurait été du pareil au même avec une désinstallation.

- Par la suite aucune forme de tentative de relance du jeu n'a pu marcher. Le message : "Impossible de lancer le jeu. Veuillez vérifier que celui-ci a été correctement installé." revenant en boucle. Ayant déplacé uplay dans le disque C: je me suis dit que le "nouveau" problème venait de là.

- Désinstallation, redémarrage de la machine, réinstallation. Et tout ça un nombre incalculable de fois mais la phrase revenait encore et toujours. En fouinant j'accède au désinstaller par le menu uplay. Peu importe toutes mes tentatives, uplay ouvre sans cesse le panneau de config pour désinstaller Anno 2070, le même panneau qui n'a plus d’Icône pour désinstaller, réparer.

- Ne pouvant interagir à ce niveau et ma patience commençant à s'épuisée... Je décide de tenter les différentes options de uplay et devinez quoi ? Absolument A-U-C-U-N-E des options ne fonctionne. La vérification ? Même phrase qu'au lancement. Le déplacement des répertoires ? Ça ne fonctionne pas. Désinstaller/Installer, rien n'y fait. Aucune modification d'aucune sorte ne peut fonctionner. Il est temps d'attaquer avec l'artillerie lourde...

- Désinstallation de uplay, suppression TOTALE d'Anno 2070 dans les clés de registre. Une heure de perdu pour nettoyer totalement le bazar. Et ça marche ! Non, je rigole, qu'est ce que je ferai là sinon... Même ça n'a pas fait comprendre à uplay qu'Anno n'était plus sur ce pc.

Pourquoi Anno 2070 démarre en hors ligne (pour demander un redémarrage impossible à exécuté dû au premier problème), pourquoi uplay malgré des manipulation relativement avancées ne donne rien, pourquoi le patch autopatcher hors ligne me sors les mêmes erreurs que uplay alors que le jeu semble complet (d'après les lancements hors-ligne), pourquoi après une journée entière perdu à tenter des trucs et à lire des solutions ne menant à rien même en s'approchant de la source de mon problème je n'ai rien trouvé, pourquoi uplay est la seule plateforme à me résister autant en terme de technique ? (Je rajouterai bien pourquoi la vie, pourquoi la mort et pourquoi la drogue au vu de la profondeur du problème...)

Quazarn
05/11/2015, 00h26
Bon... J'ai trouvé une solution, pas la solution ultime vu qu'elle consiste à faire tourner le jeu en modifiant quelques paramètres pour que ça puisse après démarrer normalement mais elle devrait aider ceux qui pourraient se retrouver dans ma situation. En désinstallant/réinstallant plusieurs fois après mon premier post, j'ai finis en désespoir de cause par passer Uplay en plus du monde admin en compatibilité windows 7 (étant sous windows 8). J'étais parti du principe que ça ne mènerait nul part mais que je me sentirai bête de pas avoir essayé et... J'ai pas été déçus. En tentant une énième fois de lancer Anno 2070, ce dernier en lieu et place d'un message d'erreur me demande quelle langue je souhaite pour Anno. En poussant il me demande alors ou l'installer. Il a ensuite récupéré la version qui attendait déjà dans le folder et j'ai pas eu à télécharger pour réinstaller. Mais c'était pas finis même sortie du program file pour être directement ajouté au disque C: , l'autopatcher continuait de planter encore et encore... Mais le "bug" de l'installation résolue, cette fois l'autopatcher offline à fonctionné. Il a exécute une partie des mises à jours avant que l'autopatcher de base ne prenne le relais au deuxième redémarrage.

Donc voilà, j'ai une méthode de résolution pour ce problème mais il pourrait être bon de faire remonter ça aux services d'ubisoft si cela arrive à d'autres.