1. #1
    Avatar de Kshn Petit nouveau
    Inscrit
    septembre 2012
    Messages
    4

    Bug : production hebdomadaire et fortifications

    Bonjour,

    Dans la dernière version (1.5.2 je crois) mais peut-être également avant, j'ai remarqué un bug (en tous cas avec le Bastion, lors de la campagne) concernant la production hebdomadaire de créatures et les fortifications.

    J'ai remarqué que les fortifications n'augmentent les productions hebdomadaires que pour les créatures qui peuvent être produites au moment de la construction de la fortification, et uniquement pour celles-ci. Si je construit un batiment me donnant accès à un autre type de créature, la fortification ne me donne aucun bonus de production pour cette créature.

    De même, si j'améliore un batiment de créature (par exemple pour recruter des cyclopes enragés plutôt que de simple cyclope), je perds les bonus de production que j'avais pu obtenir en construisant des fortifications après avoir construit mon batiment pour cyclopes normaux.

    Merci de me dire si ce comportement est intentionnel ou, si c'est un bug, dans quelle mesure il sera corrigé.

    Merci par avance (en espérant que c'était le bon endroit pour reporter ce bug).
    Share this post

  2. #2
    Avatar de Gemeaux333 Membre de passage
    Inscrit
    novembre 2011
    Messages
    79
    Les bonus de prolifération ne sont pris en compte que pour la semaine suivante en fait, donc tu as tout intérêt à construire ces améliorations avant la nouvelle semaine !
    Il est donc plus avisé de construire d'abord les bâtiments de production d'or puis ceux qui augmentent la prolifération !
    Share this post

  3. #3
    Avatar de Kshn Petit nouveau
    Inscrit
    septembre 2012
    Messages
    4
    Ahhhh donc les bonus de prolifération ne fonctionnent qu'une seule semaine, et après ils ne sont plus comptés. Ca expliquerait tout. Merci.
    Share this post

  4. #4
    Avatar de Kshn Petit nouveau
    Inscrit
    septembre 2012
    Messages
    4
    J'ai quand même regardé d'une semaine sur l'autre et le bonus de production est inchangé (si je n'ai pas modifié le batiment). Donc je pense que c'est bien un bug.
    Share this post

  5. #5
    Avatar de Gemeaux333 Membre de passage
    Inscrit
    novembre 2011
    Messages
    79
    Non, je voulais dire que les bonus de prolifération ne sont pris en compte qu'à partir de la semaine suivante !
    Share this post

  6. #6
    Avatar de Kshn Petit nouveau
    Inscrit
    septembre 2012
    Messages
    4
    Oui. Mais ce n'était pas ça le problème.

    Tu peux faire le test suivant : tu fabriques un batiment normal. Tu regardes la production pour cette créature non améliorée. Tu fabriques une fortification (tu peux vérifier dans les productions que la production de toutes les créatures ont été augmentées d'1). Tu upgrade le batiment (qui produira alors des créatures améliorées). L'amélioration du batiment augmente également la production pour cette créature, mais si tu regardes bien la production hebdomadaire pour cette créature, tu verras que le bonus de la fortification n'est plus pris en compte.

    Le test le plus flagrant est le suivant : fabrique un batiment légendaire non amélioré, fabrique les 3 fortifications, améliore le batiment légendaire. La production hebdomadaire passe de 4 à 2 ! (au lieu de passer de 4 à 5).
    Share this post

  7. #7
    Avatar de Camber92 Petit nouveau
    Inscrit
    septembre 2012
    Messages
    3
    @ Kshn

    j'ai aussi constaté ce problème.

    Et en mode combat les aptitudes (héroïsme par exemple) ne dure qu'un tour alors qu'elles devraient durer plus longtemps.
    Share this post

  8. #8
    Avatar de Gemeaux333 Membre de passage
    Inscrit
    novembre 2011
    Messages
    79
    A moins que ça n'augmente que la prolifération des créatures de bases comme indiqué, ce qui exclus les unités évoluées !
    Share this post

  9. #9
    Avatar de jplelyon5 Petit nouveau
    Inscrit
    octobre 2011
    Messages
    14

    put.. de bug

    Fausse alerte je venais de mettre une réponse mais je les effacé à l'instant, avez vous bien regardé, si la semaine pendant laquelle vous vous trouviez était une semaine normale ? pas sûr...

    ceci dis j'ai quand même trouvé un bug testé dans deux mode différent sur des semaine normale ou n'influancant pas la production de créature :

    production d'écraseur = 6 de base

    bonus de production des broyeurs et des écraseurs lors de l'amélioration de la construction : +3

    donc 6 + 3 = 9

    et quand je recrute j'en recrute 10 à chaque fois, testé et retesté. YA BON ! (et non je n'avais pas fais de fortification)
    Share this post

  10. #10
    Avatar de jplelyon5 Petit nouveau
    Inscrit
    octobre 2011
    Messages
    14
    et je viens de vérifier le bonus de fortification marche correctement
    Share this post