1. #1
    Avatar de X-_-Mathieu-_-X Membre de passage
    Inscrit
    janvier 2010
    Messages
    78

    [UPLAY/STEAM] Driver San Francisco ne se lance plus

    Bonjour,

    alors voilà le scénario :

    J'achète Driver San Francisco il y a une semaine sur Steam. Je lance le téléchargement qui me prend minimum 5h étant donné mon débit pas terrible.
    Le jeu s'installe, installe Uplay, 1er lancement de Uplay ("Uplay a cessé de fonctionner") très bien, j'exécute Uplay en mode admin, pas de soucis.

    Sur Uplay, on me demande la clé du jeu, je met la clé, cela crée un lien entre mon compte Steam et mon compte Uplay que je peux voir sur le site internet.
    Tout fonctionne très bien, si je lance mon jeu sur Steam ça lance Uplay, si je lance le jeu sur Uplay ça lance Steam, why not...

    Je fais le solo du jeu, j'avance bien, je débloque mes actions Uplay en jeu sauf que sur la plateforme je ne les débloque pas !
    J'ai déjà des points, je compte les dépenser dans les récompenses du jeu : "Impossible d'effectuer cette action pour le moment. Veuillez réessayer ultérieurement".

    Je me dis, si Uplay ne sert pas à grand chose dans cette histoire j'aimerais au moins pouvoir bénéficier des récompenses et services présents via cette plateforme.

    J'envoi un message au support. Il est estimé qu'il s'agit de soucis de connexion sur Uplay, on me fait faire des tests (ouverture de ports, fichier hosts, désactivation antivirus, parefeu, paramètre proxy de l'appli, etc.) alors que je suis bien "en ligne" sur la plateforme, connecté à mon compte, je peux jouer au jeu en multijoueur, je bénéficie bien des mises à jour, etc.

    Je pense à des soucis d'activation, je réessaye de rentrer la clé du jeu au cas où, ça me dit évidemment qu'elle est déjà activée sur mon compte.
    Quand Steam n'est pas lancé, le jeu apparaît quand même bien dans ma liste de jeu sur la plateforme, par contre je me rend compte d'une chose : quand je suis sur le site internet d'Uplay mon jeu n'est pas détecté sur PC, il est détecté sur PS3 (juste parce que j'avais participé à la Beta multijoueur du jeu qui m'a débloqué une action), mais le plus étrange c'est qu'on dirait qu'il m'est possible de dépenser des points dans des récompenses PS3 (alors que je n'ai pas le jeu, les boutons "débloquer" sont orangés), et pas sur PC (les boutons "débloquer" sont grisés).

    J'informe le support de cela en leur expliquant qu'il y a certainement une intervention à réaliser sur mon compte, le jeu ne doit être que "partiellement" activé, un truc dans le genre...

    J'avais déjà envoyé des screenshots de tout mes problèmes, on m'en demande encore pour prouver que j'ai débloqué les actions, que j'ai bien fini le jeu, etc.

    Ils essayent d'intervenir sur mon compte et on me dit qu'ils ne détectent même pas le jeu !!! Ils ne le voient pas et me demande de faire une désinstallation/réinstallation complète du jeu et de Uplay.

    En cherchant sur internet je commence à me poser des questions sur la possibilité de bénéficier des services de Uplay avec un jeu acheté sur Steam, apparemment cela est possible.

    Après quelques hésitations, je me décide à tout désinstaller/réinstaller (+ les 5h de téléchargement), on m'a donné toute la procédure, j'arrive au bout et là pas de différence !!!

    Je réfléchis à tout ce que je n'ai pas encore testé. Et je me dis, quitte à tout reprendre à zéro, je vais délier mon compte Steam de Uplay, et je vais le relier après.
    Je fais "délier" sur le site internet d'Uplay, et là je me rend compte qu'ils n'ont même pas prévu de quoi lier un compte Steam manuellement !!!!!!!!!!!!
    Ils ont pensé à Facebook, PSN, Xbox Live, mais même pas à Steam, alors qu'ils vendent un paquet de leurs jeux dessus !!!

    Steam ne me lance même plus Uplay lorsque j'essaye de démarrer le jeu, et Uplay ne me lance plus Steam. J'essaye de remettre la clé du jeu pour que le lien se refasse mais rien à faire, ça ne fonctionne pas.
    Je décide de tout recommencer : désinstallation/réinstallation (je pense évidemment à supprimer ce qu'il y a dans le registre à chaque fois), et là pareil, mon jeu ne se lance plus ! Plus de lien Steam/Uplay !

    J'ai envoyé un message au support pour savoir comment recréer ce lien entre Steam et Uplay, je n'ai toujours pas eu de réponse.

    Je vous avoue que je commence quand même vraiment à en avoir marre là, surtout qu'après cela j'aurais seulement réussi à refaire fonctionner un jeu qui marchait déjà !

    J'ai peut-être une idée de test pour mes problèmes d'actions/récompenses pour après mais je ne suis encore sûr de rien, et j'ai vraiment l'impression de régler mes problèmes tout seul !

    Si j'ai cette galère pour chaque jeu Steam à activer sur Uplay je pense que je vais péter un câble.

    Si vous avez des idées, si vous avez rencontré les même soucis ou quoi, merci de m'aider.
    Pour l'instant j'aimerais savoir comment lier manuellement un compte Steam à Uplay.

    J'ai quand même un test à effectuer :
    Ayant d'autres jeux Steam qui fonctionne avec Uplay et pour lesquels je n'ai toujours pas activé les clés (vu qu'ils n'ont jamais été installé), je compte en installer un nouveau en espérant que le lien se fera lors de la saisie de la clé dans Uplay !

    J'espère qu'un lien n'est pas généré pour chaque jeu indépendamment !!!!!!!!!!!!!!!!!!!!
    Share this post

  2. #2
    Avatar de Ubi-Cosmos Forum Manager
    Inscrit
    mai 2011
    Lieu
    Quelque part en France
    Messages
    19 663
    Bonjour,

    Le support est mieux placé que moi pour vous aider, d'autant que je n'ai pas Steam à titre personnel. Cela étant dit, théoriquement, dès lors que vous activerez un nouveau jeu Steam sur Uplay avec la clé, cela devrait relier les deux plateformes. Pour le problème des récompenses, en effet cela semble être lié au compte et je ne suis pas en mesure de manipuler cela, ce qui fait qu'il faudra attendre la réponse du support à ce sujet.
    Share this post

  3. #3
    Avatar de X-_-Mathieu-_-X Membre de passage
    Inscrit
    janvier 2010
    Messages
    78
    Bon j'ai fini par réussir en créant un raccourcis du .exe du jeu et en modifiant la cible : “C:Program Files (x86)Steamsteamappscommon[Game][Game].exe” “-uplay_steam_mode”

    Après ça le jeu était comme relié à Steam, quand je lançais le jeu celui-ci démarrait bien Uplay.
    Pour relier de nouveau mon compte j'ai désinstallé juste Uplay une fois de plus, j'ai vérifié le cache du jeu et j'ai réinstallé Uplay via Steam. J'ai dû me logger 2 fois, la première fois était pour mon compte Uplay, la seconde pour lier mon compte steam à Uplay. C'est cette interface que j'aurais voulu retrouver dans les fichiers du jeu de Steam pour le faire manuellement mais je n'ai pas pu avant cela...

    A présent il me reste le problème des actions et récompenses et je sais déjà que le support ne pourra rien y faire, tout simplement parce que mon jeu ne paraît pas "plus activé" que la 1ère fois !
    Mais j'ai peut-être une solution.

    Je leur avait envoyé mes fichiers de logs comme demandé, sauf que depuis je suis allé voir moi-même ce que ça fait lorsque j'essaye de débloquer une récompense pour le jeu, voici ce qui apparaît dans les logs :
    "Could not find game for game id 55."

    Sauf que j'ai vu qu'il existe une commande qui pourrait peut-être remédier à cela : uplay.exe -upc_uplay_id <game_id>
    donc "-upc_uplay_id 55" dans mon cas.

    Qu'en pensez-vous ?
    Share this post

  4. #4
    Avatar de Ubi-Cosmos Forum Manager
    Inscrit
    mai 2011
    Lieu
    Quelque part en France
    Messages
    19 663
    Vous pouvez essayer en effet. Ne l'ayant pas expérimenté avec un cas similaire, je ne peux garantir l'effet. Il semble clair que le souci vient de la détection du jeu et cette commande pourrait forcer ladite détection. Seulement, c'est le support qui est outillé pour vérifier les comptes, je n'ai pas ses accès, donc je ne peux malheureusement pas vous aider à ce niveau.
    Share this post

  5. #5
    Avatar de X-_-Mathieu-_-X Membre de passage
    Inscrit
    janvier 2010
    Messages
    78
    Merci pour vos réponses.

    Je vais peut-être attendre une réponse du support avant de tester, je leur ai envoyé un message pour leur présenter l'idée de toute façon.
    Share this post

  6. #6
    Avatar de Ubi-Cosmos Forum Manager
    Inscrit
    mai 2011
    Lieu
    Quelque part en France
    Messages
    19 663
    Pas de souci, je garde un œil sur le sujet pour suivre le cas.
    Share this post

  7. #7
    Avatar de Mjolnir315 Petit nouveau
    Inscrit
    octobre 2014
    Messages
    2
    Salut à toi Mathieu et vous Ubi-cosmos.

    J'aurai une toute autre suggestion a faire.

    Dans mon cas, c'est la plateforme Uplay elle même qui est foireuse.

    Je peux jouer a Splinter Cell Blacklist ( offert par Nvidia ) mais pas à Watch Dogs, splinter cell conviction ou les bundles de assassins creed acquis via steam. Du moins, je ne peux y jouer que en ayant basculé Uplay en mode hors ligne. Ce qui me laisse à penser que la dernière mise à jour de Uplay est foireuse sur certains points.

    Quand au problème de Mathieu, j'ai eu le même avec Blacklist, et il s'est résolu tout seul avec une mise à jour corrective.

    Par contre, ce que je ne saisi pas, et la dessus j'aimerais obtenir une réponse honnête, c'est pourquoi somme nous contraint d'utiliser deux plateforme de jeu distinctes, toutes en ligne simultanément.
    Est-ce une gueguerre puérile entre Ubisoft, Valve et EA? Chacune des sociétés nous a pondu une plateforme de jeux, donnant accès aux jeux des autres moyennant l'installation et l'utilisation obligatoire des ces plateformes. cela reviens à être obligé d'allumer une X box pour jouer à un jeu play station...
    Share this post

  8. #8
    Avatar de Ubi-Cosmos Forum Manager
    Inscrit
    mai 2011
    Lieu
    Quelque part en France
    Messages
    19 663
    Bonsoir,

    Essayez de décocher la case de l'utilisation automatique du Proxy dans les paramètres Uplay. Si cela ne suffit pas, pourriez-vous me décrire de manière plus précise le souci qui survient avec Watch_Dogs, Splinter Cell Conviction ou les Assassin's Creed ?

    Tous les jeux Ubisoft de ces dernières années sont associés à Uplay. La plateforme permet de réunir tous les titres de la marque, d'avoir sa liste d'amis, de débloquer des récompenses, etc. Tous les jeux peuvent être obtenus directement via la plateforme ou l'Ubishop. En ce qui concerne Steam, c'est une plateforme à part, avec ces propres offres, mais les jeux Ubisoft compatibles nécessitent de passer par Uplay pour accéder aux fonctionnalités liées.
    Share this post

  9. #9
    Avatar de Mjolnir315 Petit nouveau
    Inscrit
    octobre 2014
    Messages
    2
    Bonsoir Ubi-Cosmos.

    Merci pour cette réponse rapide.

    J'ai testé la désactivation de l'utilisation automatique du proxy sans effet sur le lancement de mes jeux.
    En ce qui concerne Watch Dogs j'ai le message d’erreur suivant qui apparait :
    "Signature du problème*:
    Nom d’événement de problème: APPCRASH
    Nom de l’application: Watch_Dogs.exe
    Version de l’application: 0.1.0.1
    Horodatage de l’application: 54182752
    Nom du module par défaut: StackHash_6dd1
    Version du module par défaut: 0.0.0.0
    Horodateur du module par défaut: 00000000
    Code de l’exception: c0000005
    Décalage de l’exception: 000007fefd620238
    Version du système: 6.1.7601.2.1.0.256.1
    Identificateur de paramètres régionaux: 1036
    Information supplémentaire n°*1: 6dd1
    Information supplémentaire n°*2: 6dd13a555687c9c6e52a7d3377b7c620
    Information supplémentaire n°*3: 3e0e
    Information supplémentaire n°*4: 3e0ef54de9288ecff91c60623bbf25a8"


    C'est en farfouillant sur un forum concernant un autre jeux que j'ai trouvé la solution temporaire du mode offline.
    Pour résumer, Uplay en offline, watch dogs fonctionne. Uplay online, plantage systématique du jeu.
    A savoir que le problème a commencé Vendredi 10 octobre 2014 soit après l'installation de la MaJ 4.8.1 de Uplay sur mon système. D’où le fait que je pense que c'est la plateforme Uplay elle même qui est en cause.

    J'ai bien entendu, réinstallé Uplay, steam et watch dogs, ai aussi fait une validation steam des fichiers, réinstallé les pilotes graphiques et audio, le reste étant géré uniquement par Windows. Et ai nettoyé la base de registre avec Ccleaner.

    Une analyse avaast et malware ne me signalent rien.
    A savoir aussi que j'ai désactivé les restaurations systèmes de windows étant sur un SDD des 120 Go pour l'OS de la machine. Steam et Uplay sont quand à eux installés sur un HDD dédié aux jeux.

    La machine elle même est un custom bitphoenix constitué d'un AMD Phenom II X4 955 Black Edition @3800 MHz monté sur une MSI 990FXA-GD80 ( ca commence a vielilir tout ca) 8Go DDR5 Corsair, une alim 1000W Corsair et une GTX660 TwinFrozR II de chez MSI.
    Share this post

  10. #10
    Avatar de Ubi-Cosmos Forum Manager
    Inscrit
    mai 2011
    Lieu
    Quelque part en France
    Messages
    19 663
    Bonjour,

    D'accord. Pourriez-vous envoyer un message au support technique (lien dans ma signature) en lui expliquant le souci et en lui donnant justement le rapport du crash ? Il pourra ainsi regarder de son côté s'il y a une action à réaliser du côté de votre compte (au cas où un élément aurait modifié suite à la mise à jour) ou au besoin reporter le souci à l'équipe de développement.
    Share this post